您好, 登录| 注册|
子站:
论坛首页    电源技术综合区
  •  发帖
  • 收藏

LM5176制作5-30V输出50A可调电源
阅读: 3320 |  回复: 25 楼层直达

2020/10/27 22:59:39
1
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
一直想做一个适用的可调电源,偶然中在ti的网址闲逛,发现有一款标称效率97%以上的升降压IC:lm5176
以前没做过升降压的电路,感觉如果做个实验电源,那么前级可以随便用一个10---50V电压,后级就能输出稳定的,我想要的电压。这样就可以做个简单的实验电源了。
说做就做了。先淘宝买了10片LM5176,12块一片。PCB先按官方的PDF画了个基本版,先把功能、波形整出来再慢慢完善。
在画板子的同时,画了一周的时间反复的看PDF文件,每个引脚的功能、如何计算外围零件、如何使用官方的设计表格。
按我自己的要求,先做个10V---46V输入的。这个输入范围是1—3节串联铅酸电池的电压范围。刚好家里也有电瓶车上拆下的6只电瓶,利用上就可以有个纯净、稳定的直流输入源了。
输出设定为14.8V输出。选这个电压只是测试升降压功能。也能给我的电池充电,装上可调电阻就可以在5---30V之间随意调节了。
有朋友可能会问:既然都5---30V可调了,干吗不做到0-30V可调?
我只能说我手太新了,还没想到如何做到0V起调。当然,这颗芯片是支持从0.8V起调的,但到0.8V的时候我估计反馈环路就不是那么容易调的了。因为上分压电阻的值接近于1欧姆,这并不利于环路的稳定。如果做成5V起调我倒是有把握的。
先挖个坑,LM5176文件稍晚些时候上传,(地方偏僻,网络不大好。)方便大家帮我修正文中不正确的地方。

标签 开关电源
2020/10/27 23:10:28
2
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

https://www.ti.com.cn/product/cn/LM5176   

这网址有ti的芯片资料,和设计软件:

计算工具名称:LM5176 Design Calculator
文件名称和大小:SNVC208.ZIP (3362 KB)

大家看着下载哦。我这里网络不好,ti经常连不上,今晚也是折腾很久都没下载下来。


这个工具挺好用的,输入各种参数,就能直接计算出外围的零件。

但是,有个坑,容我后面再讲。

2020/10/28 18:18:24
3
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

/upload/community/2020/10/28/1603879994-93973.pdf


文件部分是中文的,计算和具体功能描述都是英文。


接昨天的内容:

第一版PCB很简陋,不贴出来了,各部分均参照官网原理图。详细到每一个零件我都能给你具体型号,但是,PCB真没有,原因你懂得。
我就参照官网原理图讲讲我调试的过程吧。
板子回来,兴奋鸭,装上了所有贴片零件、MOS只装了四颗(原本设计是四个臂各两颗),电容前后各装了一颗,电感按计算的结果,装了颗用PQ3525、0.1*1000根利兹线绕四匝、开气隙电感量为2.7微亨的电感。设计的频率是在100K。
输入用实验电源限流0.1A,电压10V输入测试。
很顺利,一次通电并没短路,我的要求很低,不短路就是个好的开始。测试输出电压为15.2V,跟我计算的差不多,或许零件精度不够,精度可以再搞。先测各个点的波形,和电压。
四个臂有两路是悬浮驱动的,芯片设计的很巧妙,使用泵电源,一只0.22微法电容和一只4148就能稳定的提供电源了。原始参数是要求1A的二极管,我并没有这么高速度的二极管。也并不想装一颗SMB的管子,太占地方了。我喜欢小体积的东东。于是就用了4148,正向持续电流可以达到0.3A,我估计也足够了。特别是4148的速度,比手上的任何二极管都要快,而且耐压也在75V以上。实际我用自己的耐压测试仪测过各种封装的二极管,基本都在100V以上,手头上这种玻璃封装圆柱体的4148耐压在120V的。
这样两臂用四个零件就完成了供电,还真是佩服----集成度真高。如果让我做外围,我肯定是一个反激,输出两组隔离电压分别供电两个臂的驱动电路,再用MIC4452去驱动两颗并联的100多A的MOS。


2020/10/28 18:32:37
4
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
曾经我还怀疑这芯片能不能直接驱动4颗浮地的MOS,结果是我多虑了。输出的驱动波形上升沿只有75纳秒,下降沿100纳秒。如果不装管子,上升沿是25纳秒以内。
闲话说的有点多,测完各个点的波形,对比PDF中的波形看,基本上是正确的。第一天就这么结束,我喜欢在一个好的结果中入眠。至于能不能带载、高低压输入能不能稳定输出,我已经放下了好奇的心,毕竟好奇害死猫。瞌睡大于一切。
次日接着测试,输入电压依然是10V,输出15V多,不敢贸然输入30-40V的电压,担心PCB布局问题导致的尖峰太高毁了芯片。测量各个MOS的波形的时候,担心的事情还是发生了。
在测试悬浮驱动的两个臂的时候,芯片突然工作失常,没了输出。查出是BOOT引脚对地击穿。怀疑自己的板子有问题或者零件问题,查遍了外围也没啥零件损坏。于是12块就这么没了。
热风枪吹下,再装一片新的,显微镜下观察每一个引脚都焊接可靠没有连锡,接着上电,输出很OK。于是把第一次损坏的原因归结为意外。但即便是意外,也是有原因的,错就错在我偷懒了。没去找原因。
接着测试各个点的波形,和PDF中的波形对比,以确认自己的板子、原理、实物都没错,之后才敢加点负载测试。波形比对快完成的时候,那个“意外”又出现了。莫名的坏了。
这搞的我蒙圈几层。。。。。。。。
难道芯片是假的?水货?残次品?反复对比原理图和实物确定都OK的。于是带着一大堆疑惑去ti论坛搜索故障原因。

2020/10/28 19:38:26
5
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

发两个原理图:





2020/10/29 23:23:29
6
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
然而,TI论坛也是没人说到重点。
有几个类似情况,莫名挂了,找不到原因。也有不工作的,工作失常的,但都没有给出具体解决办法和查找故障的思路。
既然芯片冷门,咱就凉开水泡茶,慢慢来。

回忆前一天的测试情况,查找损坏的真因。两次损坏都是boot对地短路。

我的示波器是电池供电的,不存在与市电相连的问题。板子供电是实验电源,也不存在超范围供电击穿。

想了大半天,问题点还是归结到了我的示波器上。

难道是没接地,静电击穿?总得试试看,于是给示波器插上电源线,板子也换了新的芯片,查外围都OK,无零件损坏。

再次上电,测试一切正常。反复多次重复昨天的测试,示波器夹子加在SW端,探头测试boot端,怎么测试都没问题,没有再次损坏。

本着认真的原则,想重现损坏的过程,看看是否跟我的判断一致。

再扔12块钱也能学到点东西,划算。

拔了示波器电源线,用示波器内置电池供电测量,开始几次也没问题。

中间间隔个把小时,忙别的事情了,再回来测试boot的波形,一碰就挂了。

没有火花,直接没输出。

也没有任何外围零件损坏,芯片其他引脚和功能都正常,断电测量BOOT对地电阻,真的短路了。

看来真的是静电引起的芯片损坏,感慨老外芯片保护功能之强大,仅仅坏了一个功能,其他各引脚的逻辑和电压都很正常。

2020/10/31 23:19:01
7
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

好事多磨,继续搞起测试。

有了前次的经验,示波器在以后的应用中都乖乖的找根地线接大地。

输入电压从10—18V测试,都很OK。

当然都是空载测试,只有一只1K的假负载电阻。

输入电压连续变化,输出也是很稳定的。

接入电子负载,加一点点电流,再看波形都跟PDF中一致,开始有点小兴奋了,乐极生悲就这样又来一次。
输入18V,输出15.2V,负载电流加到1A的时候,效率是95%。加到3A效率下降到90%,
但波形正常。再加到4A是86—87%。蜜汁疑惑。。。。。。。。。。。规格书里给的是能输出几十A的,这才。。。。。
算了,睡一觉醒来再想问题。

2020/11/02 23:31:52
8
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

开工,测试,找效率下降的原因。

电流直接上到4A,用热成像仪观察板子上哪些零件温度高。

怀疑的对象是MOS和电感,也有电容。

热机10分钟后热成像显示MOS温度最高,为50—60度左右(具体温度记不清,不能瞎写,但就在这范围内,四个臂的温度是不同的。)

MOS是IRF3710,100V  57A  23毫欧。

选这颗是为了安全,100V耐压,远超芯片的极限电压60V。

所以前几次损坏的也仅仅是芯片。

看来内阻太大,换管子。家里还有做电动车控制器剩下的NCE8580,85V  80A  8.5毫欧。

这下效率应该能上去了吧,嘿嘿,装机测试效率。

果然,4A负载下效率稳定在91--92%之间,但距离标称的最高效率95%还有很远的路要折腾。

对比和查看实物波形,发现无论驱动低端MOS还是驱动高端MOS,驱动VGS都很低。

低端MOS的驱动用的是芯片供电8V,驱动高端MOS用的是泵电源,VGS峰峰值是7.2—7.5V。

这个固有的设计限制了MOS的选用。

普通MOS在8V以上才能达到完全打开的阶段,或许这是效率上不去的主因。

网上搜了大半天,找到NCE85H21C  85V  210A   4毫欧  220封装 。

能用国产的我绝不买进口零件。

这颗MOS看曲线图,VGS在6V的时候可以完全导通,电流达到100A以上。

正适合我需求。两颗并联只有2毫欧内阻,能满足我需求就是好宝贝!

淘宝价3.5一颗入手30颗。


2020/11/03 22:30:27
10
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

开始画第二版PCB,

在前一版的基础上8颗MOS并排装在一只散热片上,做好绝缘措施。

芯片放在MOS前面,MOS后面是输入电容、大电感、输出电容。

PCB底部是过流保护和电流检测电阻。其他零件都在顶层。

整个板子尺寸大约10*8厘米。高不超过5厘米。

电流检测部分信号走线按照官方PDF说明,用差分走线引入芯片。在

板子打样期间,特意用电桥从一堆0805电阻里挑出来十几颗阻值尽量一致的100欧姆电阻做差分信号输入用。

制作了散热片、钻孔、攻丝。选了几十颗内阻基本一致的电解。

又做了一个DC-DC反激小电源,用来驱动12V风机,准备在满功率的时候能有合适的散热。

DC-DC反激小电源是之前就画好的小板,原本是小模块的设计方案,重绕一个变压器就直接拿来用了。

调试好小电源和风机,静等第二版PCB的到来。

2020/11/04 21:46:31
12
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
新版PCB到,焊接好外围零件和MOS、电感,加了前后各一个电解,准备测试波形。
如果波形OK,那就装上所有零件开始加载。
一阵忙碌后,上12V,输出15.2V  1A,各部分波形正常。
VGS波形也直上直下,没有出现米勒平台。驱动电阻是5.1欧姆0805。
看来可以装上所有零件了。
装电容,背面加锡,装散热片。
8颗MOS,两颗一组并联,没用市面上灰白色的那种矽胶片,太厚,0.4mm。
用20mm宽的金色高温胶带在散热片上贴一条。胶带厚度0.1mm。
厚度对于热传导是很致命的。贴好胶带,MOS背面略涂一层薄薄的导热硅脂。
能多薄就多薄。涂好放在胶带上正确的位置,用7字型压板压紧每一颗MOS。
事实证明这样的散热效果是在绝缘的前提下非常理想的了。
后期热成像的图像显示温度和散热片只相差了5摄氏度。

组装完成后接好电子负载和可调电源,示波器接好在电感前后和输出端。
上电,输出OK。慢慢加载,波形如PDF中变化一致。
加载到15.2V5A,老化10分钟,用热成像观看有无发热异常。
通常有故障、或者设计缺陷的时候,在这样轻载的时候都会发现发热异常的零件。
巡视一圈,一切正常。MOS温度35度。环境温度30度。
板子上温度最高的是主芯片,55度。
个人猜想是因为芯片内部包含了强大的驱动电路。
驱动8颗100多A的MOS依然是那么从容。
继续加载10A---20A---30A。一切正常。
30A的时候,电压依然坚挺在15.2V。
输入12V41A。整体效率超过92%。
看来电路还是有改进的余地。
这时候测量温度,八颗MOS由于在同一块散热片上,温差并不明显,均在65—68度。
有个50毫米的12V0.2A小风扇吹着。电感就在散热片后面,温度55度,估计是被散热片烤的。电容几乎没温升,都是环境热辐射导致电容温度在33—38度。
距离散热片近的更热一些。
主芯片依然是55度没变化。
一切都向好的方向发展,看起来很顺利的时候通常都会有个坑在等着。
未完待续
2020/11/05 22:21:16
14
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
因为这个拓扑是升降压结构,所以看看升压没问题,就调高了输入电压,一点点调。
负载15.2V 电流固定在10A。
输入在接近14V的时候,输出电压抖了一下,电感前后的波形有了变化。
检测四个臂都有了波形。之前升压的时候只有两个臂是有波形的。
证明了主芯片进入了升降压的混合模式。
继续调高输入电压,当达到18V时,进入了降压模式。
带载10A的情况下,电感波形很干净,没有畸变。
继续提高输入电压,当加到25V时出现了异响,电感波形混乱,正要保存波形的时候芯片挂了。
瞬间没有输出。输入没有短路,电流在10毫安附近。
断电测量芯片的各个脚对地电阻,没有发现短路,再次上电12V,输出正常。
刚刚的异常情况让我瞬间懵了,芯片正常,零件正常,25V异响?12V却正常?
再试一次,大不了再烧几十块钱的事。
这次负载调到1A,输入限流到2A。
输入电压慢慢上升,跟上一次一样,在14---18V进入混合状态,18V以后变为纯降压模式。
到25V还是吱一声保护了。
故障了,没有任何零件损坏,只能有两个可能:
1. 芯片保护了。
2. 外围零件有问题。

首先芯片是可以工作在60V的。PDF是这么说的,至少也能在55V工作。
在25V出现问题明显不是保护。
我的保护电压范围也设置在10—55V,输入电压检测引脚的电压在范围内,并没有因输入电压过高而保护。
所以芯片保护的说法不成立,至少不是过压保护。
其次第二点,实际测量外围无损坏零件,这又让思维陷入怪圈。
反复阅读PDF几个小时后,发现了一行小字:
在关于C-SLOPE 的计算公式下面有一句话的说明:
A smaller slope capacitor results in larger slope signal which is better for
noise immunity in the transition region (VIN~VOUT)
翻译了下,大意是这个斜坡补偿电容越大,整个输入输出的电压范围内会越稳定,
这只是我的理解,可能并非原意。这个电容计算的是470P,实际安装的是220P的。
因为220P能还原电感上的电流波形。而470P就失去了波形的尖峰,变成略软的三角波了。
在220P的时候,各处波形都非常OK。
自以为三角波很正,没杂波就OK了。没想到坑在这里。

2020/11/06 23:18:02
17
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
换上470P的电容,再次测试,果然正常了。
从10—35V输入都正常,看来是这个电容的问题。
测量C-SLOPE电容上的波形,三角波在小的时候滤的像猫耳朵一样。
电流30A的时候波形正常了。是个三角形,看的到角。
继续加大输入电压,38V就异响了,但是没停机。
估计这个电容还需要加大?以改善输入输出的稳定性?
看PDF里的公式,这个电容的确和输入电压的范围有关,但计算很复杂。
这个表格也只能参考。于是秉持自己动手丰衣足食的精神,一点点的改动C-SLOPE。
不断的加贴39P的电容,最终得到的值是在10---55V输入范围内正常工作的电容量为680P。
虽然在轻载的时候波形不再是三角波,但无所谓。
看来芯片对电流的检测是很宽容的。
至此,整个输入范围和输出都能满足我的要求。
也测试过50A输出,MOS的温度达到了85摄氏度。
经过细节的多次改动,整机效率达到了最高94%以上。
效率最低的时候是在最高电压输入的时候,52V输入,15.2V输出,50A。
效率只有92%以上。
四个臂中,降压时,输入的第一组MOS最热。
这组MOS由电容泵供电驱动,驱动VGS电压是6.5V—7V。
想再通过增加MOS并联的方式来提高效率恐怕是行不通的。
主芯片已经很累了,驱动8颗大电流MOS需要很大力气的。
下一版我打算改为专用芯片+隔离变压器驱动,让主芯片能降低一些温度,工作会更可靠一些。
输入和输出电压电流都用差分放大后给单片机做个显示功能。
散热片用热管,面板用PCB画一个打样,外壳用个淘宝上购买的小型电脑机箱就OK了。
理想很丰满,现实很骨感。想的太美又掉坑里了。下回再说是什么坑。

2020/11/18 19:26:19
19
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
新的PCB到了。
杜绝了前面发现的那些问题。风道和散热片也有了优化。
焊接过程略过,装机后用电子负载测试OK。
输出调为14.8V,然后关机。在负载上接入一只12V20AH电瓶。
再开机,神奇的事情发生了,我的输入可调电源冒烟了。
30V5A的线性可调电源。怎么会冒烟?好郁闷。
但很明显是在我开机瞬间,电源冒烟了。
还好我有四台3005电源,平时可并可串,应用灵活。
节省时间换一台再试,瞬间又挂一台可调电源。
虽然损失两台电源,但问题点就很明显了,出在板子上。
烦人的板子啊,不管了,先冷静下,换个事情做作先。
找来一堆很少用到的三极管,把电源修好先。
电源拆开发现是输出部分过压了。
输出电容挂了,输出上的其他小零件也挂了几个,但整个辅助电路和显示控制部分完好。
换好电容,反复测试OK,两台可调修复完毕。一个下午就这样过去了。
晚上静下心来想问题的来由:
损坏两台电源,肯定是板子出问题了。
一步步反推,接电池之后连损两块电源,而之前各种测试都很OK。
问题在电池上?难道不能接容性负载?之前测试都是用电子负载的。
电池、容性负载、为啥电源坏了?被高压损坏?我的DC-DC产生的高压???
说出来我自己都不信。疑惑啊,来反推一次原理图:
当输出接入电池的时候,各MOS都处于关闭状态,电感上无电流,输入处咋会产生高压?
当开始上电的时候会进入软启动,脉宽是逐渐打开的,电感中电流并不大。
但是,突然发现了一个问题:刚开始的时候,由于脉宽逐渐打开,SW2上就没有多少电压。
SW2处的电压是低于电池电压的。此时Q7Q8打开了,电池的电倒灌进来。。。。。。
然后逆向升压了。。。升了。。。了。。。
唉,被电池打败了。

2020/11/19 21:16:41
20
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
接着有了预防方案,在输入端串入一只6A10二极管,挂上示波器看输入的电压是怎么变化的。
上电瞬间,的确是反向升压了,无论输入电压是低还是高,都是升压。
电压会叠加在输入电压上,造成我的可调电源损坏。
咋办捏,想想吧,办法总是有的。
输出的Q7Q8两颗MOS更换成二极管,不就一劳永逸了?
嗯,牺牲点效率把。去掉MOS,去掉驱动电路。
换上60A45V220封装的肖特基,理论上杜绝了逆向升压。
实际还得试试才知道。二极管在高温时候的漏电流还是不小的。
再次试机,非常理想。没倒灌。电池负载正在充电。
测试的时候,限流电阻用的0.020欧姆,因此输出电流只有2A多。
输入电压可以随意在10—50V之间调整。
至此,整个电源调试完毕,也只能用二极管替换Q7Q8了。
效率下降很多,但升降压功能是完美实现了。
目前正在画下一版。恢复Q7Q8,提高性能,但在初始几秒的时候会屏蔽掉Q7Q8的驱动信号。

这样在初始的几秒,MOS当二极管用,实际上并没有多少损耗。

主要的作用是防止负载为电池的时候,逆向电流形成升压,导致输入部分损坏。

几秒后,再接通驱动。当然,PCB上也给Q7Q8并了一只60A45V肖特基。
用于防止突然大电流冲击。MOS的体二极管速度可远不及肖特基。
这样处理后就兼顾了效率和安全性。
画板子好慢,一点点尺寸都需要推挤。大家需要等个把月了。
画好后再来跟大家分享。到时候公布PCB。

2020/11/26 10:55:43
21
dy-Mkbt3LwQ
电源币:0 | 积分:3 主题帖:0 | 回复帖:1
LV1
士兵
顶一个,非常赞!有个地方没看明白  “恢复Q7Q8,提高性能,但在初始几秒的时候会屏蔽掉Q7Q8的驱动信号。

这样在初始的几秒,MOS当二极管用,实际上并没有多少损耗。

主要的作用是防止负载为电池的时候,逆向电流形成升压,导致输入部分损坏。

几秒后,再接通驱动。" 这个怎么实现啊?
2020/11/26 11:12:41
22
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

最简单的办法就是用一个三极管、一个稳压二极管、一个电容。

当电容上的电压高于稳压管的时候,击穿稳压管,三极管导通。

这样就可以用电容的充电时间来延时。

三极管可以去控制光耦、小型继电器或者模拟开关电路。

这样就可以在一段时间内切断MOS管的驱动信号。

2020/11/03 08:40:09
9
hylylx
电源币:120 | 积分:40 主题帖:2 | 回复帖:1993
LV9
军长
热泪盈眶前来顶帖,正需要呢
2020/11/03 22:31:18
11
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令
多谢捧场,我会持续更新整个制作过程和走过的坑。
2020/11/05 17:30:05
13
ymyangyong[版主]
电源币:2000 | 积分:468 主题帖:6 | 回复帖:6493
LV12
元帅
顶帖看直播
2020/11/05 22:25:50
15
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

顶帖必回。

码字真的难啊。只能每天挤一点点了。辛苦版主持续关注。

2020/11/05 22:41:59
16
zhiyiyunmeng
电源币:0 | 积分:0 主题帖:9 | 回复帖:334
LV6
团长
顶一个,焊接的实物来一个嘛
2020/11/06 23:20:44
18
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

原设计卖了。所以很难贴图上来。

原因大家都懂得,我会抽空再做一个简化版的留下来自己用。

后续会有制作简化版的实物图。

鉴于某些原因,上面两张原理图也是删除了很多内容的,只保留了基础功能。

希望能理解。

2021/01/15 14:56:18
23
Mv_vM
电源币:0 | 积分:3 主题帖:0 | 回复帖:1
LV1
士兵

楼主你好,我用LM5176做的 一个输入8-25V输出 12V的电源板,板子大小不大,5*7cm,希望功率越大越好,不加散热器,测试发现几个问题:

1.空载功耗都比较大达到了有几十个毫安,这个是正常的吗

2.当我升高输入电压时,电感叫声越来越大,到18V时,此时空载电压不能稳定到12V(此时输出12.6V),但是这个状态加上负载能工作

3.当输入电压为19V时,输出电压为13.08V,此时电感不叫,功耗此时显示为0,这个可能是什么原因导致的呢?

2021/01/16 08:34:58
25
tanb006[版主]
电源币:43 | 积分:40 主题帖:206 | 回复帖:939
LV10
司令

第一个问题,空载功耗很正常。芯片空载的时候都有大约50度的温度,这个是正常的。

第二和第三个问题应该是同一个原因,就是芯片工作在升降压的混合模式了。可以仔细调整电流采样的走线,一定要差分形式,和斜坡补偿电容来减轻这个情况。

2021/03/13 21:33:52
26
dy-MVGfwCPY
电源币:0 | 积分:3 主题帖:0 | 回复帖:1
LV1
士兵

楼主你好,我在用lm5176设计buck。

测试中发现当电流过大时,输出电压就开始跳动,SW1的占空比直接从30%降到2~3%,波形更像阶跃,请问可能是哪里出现问题呢。

2021/01/15 16:35:32
24
cpu51
电源币:0 | 积分:1 主题帖:92 | 回复帖:64
LV6
团长

用了这个混合模块,他们做到了0-7000V的电压调整,而且是0V起调,说是线性电源,懂的大神科普一下。我准备买一个,加上触摸屏,做个0-60V的玩玩。

该帖有赏
客服热线
服务时间:周一至周五9:00-18:00
微信关注
免费技术研讨会
获取一手干货分享

互联网违法不良信息举报

Reporting Internet Illegal and Bad Information
editor@netbroad.com
400-003-2006