您好, 登录| 注册|
论坛导航
您好, 登录| 注册|
子站:
论坛首页    电源技术综合区
  •  发帖
  • 收藏

LLC 恒流模式下带载就炸机
阅读: 540 |  回复: 16 楼层直达

2019/11/23 11:56:59
1
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长

QQ截图20160321155901  【活动进行中……】礼遇感恩节!参与顶楼  免费送仪器

QQ截图20160321155901   【风采汇】参与有奖!获奖作品分享大赛



各位大侠,小白我做了一个全桥LLC电源,芯片用的是MC33067,这是一款老芯片,之所以选这款芯片,是看它的外围电路简洁,现在遇到了一个问题,就是恒流模式下,一带载就炸机,但是在恒压模式下,却又可以正常工作,效率在94%左右,希望大侠们能够指点指点,是什么原因导致的。

参数为: 输入220V  输出72V/5A                 

K值取4    最小工作频率57K ,最大工作频率211K                 

PQ3532   谐振电容 18nF   谐振电感200uH    励磁电感800uH              

匝比为4.7   初级38S   次级8S              

自认为是恒流环参数不合适,但是试了很多的参数,还是不停的炸机,炸的心里都有阴影了

这是第一次做LLC, 希望得到大家的帮助,谢谢

死区时间我设置为450nS,  芯片自带的误差放大器被接成了电压跟随器的形式,反馈量要在2.5V--1.5V之间,芯片的工作频率才会进入线性区

/upload/community/2019/11/23/1574481204-26918.pdf

标签 LLC
2019/11/25 10:50:02
2
水乡电源[版主]
电源币:372 | 积分:51 主题帖:10 | 回复帖:754
LV9
军长

输出360W,感量800uH,

看你的谐振电感200uH,谐振电容18NF,

似乎变压器和谐振参数不合适,

原理图呢?

输入多少

2019/11/25 12:00:21
3
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长

    大侠,前面的滤波整流跟变压器隔离驱动都是常规的,没有加PFC, 220V输入 所以就没发

关键是在恒压模式下能正常工作,恒流模式就不行,我怀疑是电流环参数没调好,但我对反馈原理理解不深,

变压器参数是这样的

2019/11/25 14:24:06
4
水乡电源[版主]
电源币:372 | 积分:51 主题帖:10 | 回复帖:754
LV9
军长

你第一步,匝比就算错了,

我算的是,CR=65NF     LR=54uH,;LP=215uH,

取CR 2个333并联,LR=55uH,LP=220uH,

理论匝比2.13,实际匝比2.38

2019/11/25 15:54:07
5
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长

 大侠,我这是全桥拓扑,不是半桥哦,匝比应该不会错啊

我现在做的只是想验证一下理论知识跟实际的是否一样,并不是出产品,只是想多学点东西/upload/community/2019/11/25/1574668441-65335.pdf

2019/11/25 17:15:53
6
水乡电源[版主]
电源币:372 | 积分:51 主题帖:10 | 回复帖:754
LV9
军长

全桥LLC,那算的是对的,才300多W做半桥LLC多便宜,做全桥LLC浪费成本啊。

看一下你的同一下管的VDS和VGS波形。


然后仔细看了一下,有几个位置的电阻设置不是很好,

R47、220R应改成1K以上,R50  3K应改成1K,R55要去掉,


R61  2K改成1K,C30 去掉,R56  10K也改成1K,

运放的9脚接一个104电容到地。


再就是根据你的输出电流采样电流电阻是2个2512的0.02R并联,也就是0.01R,

5A电流在0.01R的压降是0.05V,IC7B是放大21倍,基准是1V,恒流点应该是1/21/0.01=4.76A

2019/11/25 18:30:11
7
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长

好的,谢谢指点,我试试看,到时候再回复您

2019/11/26 14:14:03
8
zsx097
电源币:70 | 积分:10 主题帖:0 | 回复帖:41
LV3
排长
炸机的原因,一般是拓扑结构有问题,或者参数有问题,再仔细看一看MC33067的DataSheet(说明书)。
2019/11/26 14:17:07
9
水乡电源[版主]
电源币:372 | 积分:51 主题帖:10 | 回复帖:754
LV9
军长
33067的死区是固定的?还是可调死区?
2019/11/26 20:26:22
11
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长
死区时间是可调的,我现在设置的死区时间为450nS  这个死区时间应该是很大了
2019/11/26 18:05:03
10
xiaoliu05
电源币:32 | 积分:5 主题帖:5 | 回复帖:26
LV3
排长
最大工作频率 与MOS不皮配,可降低你的最大工作频率。
2019/11/26 20:36:34
12
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长

大侠,炸机跟最大工作频率应该关系不大吧,因为空载的时候,或是恒压Q值很小的时候都是正常的,这个时候工作频率应该是很高了

在恒流带载的一瞬间炸了,我倒是认为是工作频率低了,在加载的瞬间,相当于短路,只有工作频率很小,才能维持并传递次级所需的能量啊

2019/11/26 20:41:28
13
水乡电源[版主]
电源币:372 | 积分:51 主题帖:10 | 回复帖:754
LV9
军长
看看同一下管的VDS和VGS波形
2019/11/26 20:59:01
14
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长

 前辈 这几天要做别的事,还没来得及试,等把别的事做完了,我再把波形图发出来,到时候麻烦您再帮我分析分析,在此先谢谢您了

2019/11/27 14:04:00
15
xiaoliu05
电源币:32 | 积分:5 主题帖:5 | 回复帖:26
LV3
排长

我分析是:恒流输出时,当输出电压低时,这时工作频率会高,没有工作在最佳谐振点。导致开关损耗增加。所以你说的 恒压没问题,恒流就烧机了。

你可以试试把最高频率压制在150KHZ以下。或换一种开关速度快一些的MOS。

2019/11/27 16:24:10
16
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长

恩,这段时间来不急调试,等过段时间试了就把结果告诉您们

2019/12/03 09:17:59
17
tangze
电源币:0 | 积分:2 主题帖:4 | 回复帖:4
LV3
排长

大侠们,还是不行,又炸了,板子都翘铜皮了,只能再做个新的试了

该帖有赏
客服热线
服务时间:周一至周五9:00-18:00
微信关注
免费技术研讨会
获取一手干货分享

互联网违法不良信息举报

Reporting Internet Illegal and Bad Information
editor@netbroad.com
400-003-2006