您好, 登录| 注册|
论坛导航
您好, 登录| 注册|
子站:
论坛首页    电源技术综合区
  •  发帖
  • 收藏

3525可调开关电源,电流反馈后打隔,求解!
阅读: 3705 |  回复: 56 楼层直达

2019/01/03 12:56:02
1
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

QQ截图20160321155901   免费送!!!基于罗姆1700V碳化硅的AC/DC 免费试用

QQ截图20160321155901   号外!号外!罗姆碳化硅功率管评估板免费试用



电压反馈,取输出电压分压再比较,控制三极管导通,反相拉低3525的9脚,控制电压,这部分没有问题,纹波也还能接受

电流反馈部分,先从分流器取样放大100倍后送到电压比较器,与给定电压比较后输入下拉3525的9脚控制占空比

问题在于电流反馈后能调节输出电流,但会出现150-200HZ频率的打隔,没办法实现线性调节

各位,这个问题应该怎么调整?

2019/01/03 13:00:23
2
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
调整过3525的R40 比较输出的R27,比较器也试过与地分压,改变比较器供电,也调整过比较的反馈回路,输出均会打隔!
2019/01/03 14:29:47
8
firefox886
电源币:231 | 积分:5 主题帖:9 | 回复帖:645
LV9
军长
要调整你电流误差放大器的环路参数!
2019/01/16 17:43:45
49
核子郡丹礼
电源币:0 | 积分:3 主题帖:1 | 回复帖:5
LV1
士兵
把2脚和1脚接一起,R42改接到16脚和9脚之间,阻值加大,R40建议放到Q2的1脚到地之间,这样可以在Q2BE极形成负反馈。
2019/05/01 21:05:33
57
3333a
电源币:0 | 积分:3 主题帖:0 | 回复帖:1
LV1
士兵
3525的10脚怎么没有下拉电阻 会出现不稳定的 用三极管简直成开关作用 很容易饱和 
2019/01/03 13:00:54
3
hylylx
电源币:98 | 积分:40 主题帖:2 | 回复帖:1641
LV9
军长
2019/01/03 13:58:57
4
firefox886
电源币:231 | 积分:5 主题帖:9 | 回复帖:645
LV9
军长
你能上一个完整的图么?
2019/01/03 13:58:57
5
firefox886
电源币:231 | 积分:5 主题帖:9 | 回复帖:645
LV9
军长
你能上一个完整的图么?
2019/01/03 14:17:49
6
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

/upload/community/2019/01/03/1546496238-24002.pdf

麻烦各位帮忙分析下什么问题!

2019/01/03 14:21:32
7
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
导出PDF文件里面的文字变成了鸟语!
2019/01/03 17:55:24
9
ymyangyong[版主]
电源币:2018 | 积分:478 主题帖:3 | 回复帖:6022
LV12
元帅

建议R30后面加个滤波电容。另外看下,12v基准分压是否稳定。

2019/01/03 18:02:32
10
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

R30前面或者后面都有测试过C滤波或者并CR滤波,问题依旧

电压反馈环与电流反馈环是一样的比较器,但电压反馈未出现问题

电流反馈目前是取样输出分流器,使用358运算放大器放大100倍,再和电压一样的比较方式还行输出拉35259脚的三极管

很明显是电流比较器一有输出就直接拉低35259脚,然后又恢复,这个频率在150-200HZ

比较器输出的肯定是脉冲信号的,但电压环的频率达以M频率,而电流环的才200HZ

这个问题不知道从什么地方下手!

2019/01/03 18:41:33
11
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
会不会与输出滤波的大电容有关,电容放电前电流比较大,拉落了前级占空比,然后放完电又放开占空比好让电流达到输出要求但一般开关电源都是先滤波后取样的
2019/01/03 20:18:31
12
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

你这问题,就是3525的9脚的三极管引起的,不要这个三极管,三极管速度没4148快,

用2个4148,分两路,一个4148控电压,一个4148控电流,再用运放控4148,注意运放的正向和反相输入问题,也就是运放的真值问题,

电压反馈用一个运放可以,电流又是放大 又是控制,电流要两个运放,

电流信号放大是101倍,不是100倍


还有你这个2904是比较器 还是运放,如果是393这类的专业比较器,是不能做电流反馈的,LM358和LM324就可以

2019/01/04 07:16:52
13
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
2904是通用运放,我在网上看过 不用三极管是怎么个接法,副电源是单电压的,只有正12V 能否给个图学习学习
2019/01/04 07:18:36
14
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
如果是三极管的速度问题,为什么电压环又可以稳压,两边电路是一样的,也是一样的器件,望指教
2019/01/04 08:34:01
15
firefox886
电源币:231 | 积分:5 主题帖:9 | 回复帖:645
LV9
军长
把你的电流环调慢点,电压环要快,电流环要慢!三极管要工作在线性区才行!
2019/01/04 10:33:10
16
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

如何把电流调慢?

刚才把输出滤波电容拆了下来,上电测试还是会打隔,频率也差不多,可以确定这个不是因为电容充放电原因造成的

把电流反馈部分比较输出后面加了大电容滤波,反馈拉三极管只有一点点纹波了,但依然会打隔,只有完全是稳定线性下才正常

为了得到线性反馈输入把放大比较电路改成下面这样,但还是打隔

2019/01/04 10:47:20
17
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

今天还特意测试一下电压反馈时的波形,频率是1.8~3M频率之间,说明2904这个运放还有环路上的各器件是没问题的

两闭环是一样的电路,电流放大速度也是跟得上的

再把反馈输入端与输出端波形对比,两组波形基本看不出时间差,是只波动量不同,反馈端有0.1V左右波动,而输出端则完全关闭,电压从20V掉到0V然后又重新回到20V保持150~200HZ频率

有什么办法可以让电流多次取样,然后再按一定频率进行比较,这样应该能稳定,只要对三极管下拉调整速度慢于取样速度这样应该能线性

或者在反馈时先平衡一下原来下拉电压再叠加调整拉三极管的电压

2019/01/22 12:34:42
50
zwic
电源币:20 | 积分:5 主题帖:36 | 回复帖:70
LV5
营长
把电流放大的那一极取消或者把放大倍数减小,C43取消,在Q2的发射极串一个电阻。
2019/01/22 13:35:38
51
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长
第50贴的,别瞎扯但了,放大那一级不能取消,跟这个放大无关
2019/01/29 10:44:37
53
zwic
电源币:20 | 积分:5 主题帖:36 | 回复帖:70
LV5
营长
我做过几款充电器都没有加放大那一极,恒流精度基本上都小于3%的误差,下图就是我其中一款200W充电器的恒流部分。已经量产了两千多台了,目前没有出现大的问题。
2019/01/29 16:17:10
54
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

你才200W,当然不要电流放大,人家是200A,需要放大不?

才量产2千多台?能跟量产20万台比不?


电流75A以上的,用的是分流器,分流器的两端只有75mV,是必须要放大的,不然没法进行细腻精密的恒流,

一些井底之蛙见识肤浅,才认为不要放大,


200W的充电器,检测电流电阻两端的电阻压降是0.2~0.3V,当然不要放大。

2019/01/30 16:07:25
55
hbzjcjw
电源币:32 | 积分:0 主题帖:92 | 回复帖:1925
LV10
司令
你说的很对,这个主要是压降决定的,在电流大电压低的充电器12V50A与60V10A还是有区别的
2019/01/04 10:48:49
18
firefox886
电源币:231 | 积分:5 主题帖:9 | 回复帖:645
LV9
军长
你把三极管与运放输出连接在一起,参数表出来我看一下!
2019/01/04 11:37:47
19
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

三极管的线性区是B极电压在0.5-0.7V,用三极管不出问题才怪,你的三极管直接饱和了,

用4148和运放组合控制多好啊,不要用三极管,

2019/01/04 11:39:35
20
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
求图
2019/01/04 11:57:29
22
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长


画了个草图,不知道能不能帮助你,如有错误,欢迎指正,

方法一、可以用一片324用其中3个运放,

方法二、图中324的A部分是恒压,可以 由虚线中的431部分替代,然后另2个运放,可以用8脚的LN358替代,

后者调试简单,精度更高,但多了一个431,成本......

前者全部由324控制,调试复杂一点。

看楼主取舍,我都是做后者,我做过的2A到40A的不同功率的机子都能恒定

2019/01/04 11:58:53
23
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

下面是电流闭环后波形,3通道是输出电压波形,1通道是三极管B极波形

可以看到输出电压完全是脉冲式的,1通道是三极管B极波形的600mV左右波动波动范围约是150mV左右,但对输出影响却是这么大,可以完全关闭输出

再下面就是电流取样放大端与比较器输出端波形

3通道是比较输出到三极管波形,1通道是取样电阻放大101倍后波形

很明显放大电压是比较线性的,但比较后就是大起大落了,但通过滤波后到三极管B极的还是调整到比较线性的

主要原因为什么频率这么低,比较器输出是脉冲是肯定的,电压环频率达到MHZ,电流环才20~60HZ

各位这样的问题如何调整?

2019/01/04 11:46:00
21
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

电流和电压开环时输出波形和三极管B极波形,3通道是输出电压波形,1通道是三极管B极波形

电压闭环后波形,可以看到电压反馈频率是40K~3MHZ跳动,输出电压被控制在3V左右,有一点点纹波 3通道是输出电压波形,1通道是三极管B极波形

2019/01/04 12:10:17
24
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

图在上面,已经上传了,

三极管延时很大,你不知道吗?我做过实验,用三极管反相驱动就是不行,改用逻辑门的反相器就OK。

充电器的电流都是恒定,我见过的从1A起,到几十A的,不等功率,

都没有用三极管控制的,今天看你用三极管,真是开了眼界了。



2019/01/04 14:14:56
26
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

刚试了一下,不用三极管确实可以减少纹波,至少不会打隔了,电流可以按给定电压进行调节,但没办法调到0输出

3525的9脚到1K电阻电压是1.2V,而到了调节电压点是0V,输出电流最低也是14A,

再有就是调电流时变压器会鸣叫,我在3525-9这里并了一个104电容和39K电阻,声音小了很多,但还是能听到

接下为准备把电压部分也改为反相输入,解决变压器鸣叫、解决电流电压调零

2019/01/04 14:18:52
27
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

用三极管是因为之前拆过一台电镀电源,上面就是这样的电路,可能是电镀电源对纹波没有要求

2019/01/04 14:23:55
29
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
我现在计划做0~200A输出的,现在用60V可调电源输入调试,可以带到120A了。但是电流没办法调到0A,最少也是14A,就是3529-9没办法用运放拉到0
2019/01/28 19:58:36
52
hbzjcjw
电源币:32 | 积分:0 主题帖:92 | 回复帖:1925
LV10
司令

从0V起调,运放必须是正负供电

2019/01/04 13:49:04
25
hylylx
电源币:98 | 积分:40 主题帖:2 | 回复帖:1641
LV9
军长
就你提供的图纸看电流能够调节?表示怀疑,你这电流取样相位搞反了,知道吗。
2019/01/04 14:22:19
28
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
是反了的,我调试的时候才改过来,把开关电源取样方法和用电器的取样搞一样了
2019/01/04 15:12:43
30
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

我传的图不是调节电流的,只是能恒流的。不打隔;

充电器2-40A都是这样恒流,没有用三极管的,


电流相位反?怎么反?运放的输入,从正相  反相都能输入,看你怎么做了,结合你的终端电路。我这个图适合我的终端电路。

充电器电流恒流都是这样的,那个电阻是光耦下来的,我没说叫你按照图一模一样去做,是参考图。图主要是体现出4148的存在,体现出不要三极管。


你想0V  0A起调,可以把运放搞正负双电源啊,还有,你也可以用4148去控光耦啊。办法多的是

2019/01/04 15:42:40
31
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

上面图只是解决你的打隔问题,没考虑到0V 0A的问题。

想做0V 0A起调,不是你这种做法,

做0V 0A起调,需要用到精度高的运放


2019/01/04 15:58:23
35
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
我想用运放拉光耦调零试试,主要是我们这很多2904,但拉光耦会不会像拉三极管一样速度不够。
2019/01/04 15:44:15
32
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

非常感谢,水乡电源[实习版主]的帮助

对于新手来说,帮助太重要了

2019/01/04 15:54:59
33
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

OP07运放的精度很高,Vio  60uV

TL084  TL082  速度也可以

2019/01/04 15:57:20
34
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

像大功率可调电源,没必要搞0V起啊,有4.5V起就可以了,

毕竟用大电流是5V以上用的多,5V以下用的少

2019/01/04 15:59:36
36
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
是的,是的,主要是用来老化产品的,没必要做到0V,只是心里有点完美主义
2019/01/04 16:31:35
37
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
刚试了一下用4148控光耦,和三极管一样输出会打隔,看来看是用运放直接拉比较可靠
2019/01/04 16:53:10
38
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

你图中是越过了1脚  2脚,如果把1脚   2脚   9脚,运用起来,会不会效果好一点?


我的反激  正激  半桥  全桥,用4148控光耦  光耦再控芯片,不打隔的

2019/01/04 17:38:44
39
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

/upload/community/2019/01/04/1546594637-11302.pdf

刚才把电路改成这样,用4148接光耦,光耦再拉3525-9,出现的问题和我用三极管是一样的打隔

请教这部分电路应该怎么改?

2019/01/04 17:39:30
40
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
3525自带的运放不好用,我以前试过的,
2019/01/04 20:12:45
41
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

按道理说芯片自带的运放是OK的,

不要R40直接控,  再在光耦4脚加个10K的上拉,试过吗?


问一下,你输出多少V    A?

2019/01/04 21:10:14
42
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

上接了还是打隔,计划是做30V100A的,100V时就30A

刚看了http://www.dianyuan.com/bbs/2445485.html

这个帖子,打算改用他这个反馈网络,和他一样,遇到了电流不可调的问题,暂时没发现什么问题,给他发了信息,不知道有没有回复!

2019/01/05 10:49:42
43
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

你还是用双电源给运放供电吧,这样0V  0A起调 

还有你布板有没问题?

PCB方便截图看吗?正面和反面

2019/01/05 14:16:18
44
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长

我昨晚简单地搭了一个反馈环路,用负压可以做到0V起调,纹波也能接受,但只要一接光耦或者三极管就会打隔,只能用运放直接拉。

电路用了下面这个图,没办法控,要么全开,要么全关,我分流器是200A75mV的,直接用来对比对线路要求比较高

电流部分我打算先正向放大再给运放比较拉3525-9

2019/01/05 21:26:05
45
kl0766
电源币:5 | 积分:1 主题帖:25 | 回复帖:44
LV5
营长
谢谢水乡电源版主,问题已解决,多次试验只好放弃原来的三极管或者光耦方案,直接使用运放下拉3525-9 参考是茂老师的方案,经过几次调试还是很可靠的,各项参数基本理解 最后使用调速运放和双电压实现了电压电流0起调,这个问题可以关闭
2019/01/05 21:54:00
46
水乡电源[实习版主]
电源币:208 | 积分:46 主题帖:9 | 回复帖:628
LV9
军长

本来做0V 0A起调,就是需要双电源供电,早叫你不要用三极管,因为三极管有延时,

顺便问一下,使用了哪个型号的运放?把解决的过程分享一下,方便让以后更多的新人学习

2019/01/11 17:28:27
47
老井
电源币:0 | 积分:3 主题帖:1 | 回复帖:12
LV2
班长
精彩,受教
2019/01/16 14:13:08
48
lqh1972
电源币:6 | 积分:7 主题帖:40 | 回复帖:27
LV5
营长
不错的文章!
2019/04/13 22:56:15
56
起名字太难
电源币:0 | 积分:3 主题帖:0 | 回复帖:1
LV1
士兵
楼主有没有全图啊,我有个3525,LT084CN,TL324N 方案的0-60v 0-10A的可调电源,开机可以正常,调压调流也正常,就是带载只能炸滤波电容,先发热然后冒烟了,两只250v1200uf只炸下面那只,另一个完好,(炸了好几个了)求楼主指点,怎么维修。。
该帖有赏
客服热线
服务时间:周一至周五9:00-18:00
微信关注
免费技术研讨会
获取一手干货分享

互联网违法不良信息举报

Reporting Internet Illegal and Bad Information
editor@netbroad.com
022-58392381