您好, 登录| 注册|
论坛导航
您好, 登录| 注册|
子站:
论坛首页    电源技术综合区
  •  发帖
  • 收藏

UC2843反激,带载电压降低原因求助
阅读: 835 |  回复: 18 楼层直达

2018/10/16 15:51:41
1
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长

QQ截图20160321155901  玩大发了! 英飞凌最新无人机套件LARIX免费试用 招募中

QQ截图20160321155901  想学你就来!DSP学习板免费试用 限时申请


设计一款基于UC2843的反激电源,输入40V,输出24V/2.4A,工作频率100KHZ,工作于断续电流模式,变压器采用PQ2620,匝比原边6匝(电感量15uH)、二次5匝、辅助绕组3匝。调试空载输出电压23.8V,随着负载逐渐增加输出电压会有微小跌落,满载时输出电压跌落至23.3V,但波形稳定,无抖动。 满载时测试Mos电流,仍然工作于断续模式,且变压器也没有饱和,并测试了Mos的Vds波形也正常。    期间我更换了另一个厂家的变压器(设计参数相同),仍然没有改善,希望大神帮看看有没有改善这个问题的办法QQ图片20181016153035

由于这个反馈支路的低频增益为(R32/R33)*CTR,所以我试着增大R32/R33的比值来提高低频增益以降低静态误差,但实际上并没有什么效果。

2018/10/16 16:06:18
2
weixiu123
电源币:313 | 积分:1 主题帖:0 | 回复帖:264
LV5
营长
顶起来!望早日解决
2018/10/16 16:12:30
3
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长
2018/10/17 11:03:02
4
jlh213
电源币:59 | 积分:11 主题帖:5 | 回复帖:66
LV4
连长

1、R32电阻值太小,建议4.7K;

2、R33,R34和R38的电阻值太大,图不能放大,有点看不清。建议:若R33,R34和R38连在一起了,R34短接,D10断开,R33,R38更改为4.7K。

3、PC817的CTR是指电流,Vth的电压与流经R32的电流有关,而R32的电流又与流经光耦的发光二极管的电流有关,目测你流经光耦发光二极管的电流很小,可能导致Vth的电压限制了占空比。

2018/10/17 11:57:33
5
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长
好的,稍后去试一下,谢谢
2018/10/17 13:56:17
6
juntion[版主]
电源币:1010 | 积分:213 主题帖:2 | 回复帖:792
LV9
军长
這你連試都不用試, 把R48回授點拉到P2_Pin1 就好了...你的線降高啦.....
2018/10/17 20:14:38
9
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长
您好,版主。我刚刚测试的下输出LC滤波前级的电压(C28)两端电压:如果使用万用表测试,则:空载23.96,满载23.85V,0.1V的压降。 如果使用示波器测试(普通探头,乘10档位,测量C28两端),则空载23.96,满载23.75V,0.2V的压降。而且在满载的时候会有滋滋的声音,比较大。      现在还没有想明白示波器为什么会对输出电压有影响,以及变压器为什么会有这么大的异响。
2018/10/17 20:17:32
10
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长

刚刚测试了一下满载时mos的电流波形,波形没有畸变,只是幅值有变化,这个可能跟我前级40V供电有关,这个40V供电有2V左右的纹波。 但是变压器依旧有较大的滋滋声音。

2018/10/18 08:31:33
12
boy59[版主]
电源币:215 | 积分:90 主题帖:50 | 回复帖:266
LV9
军长
从现象上看像是自激震荡了(输入的2V纹波频率多少?),补偿电阻用的是8MΩ吗?
2018/10/18 12:13:26
13
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长
431的补偿电阻现在用的是300K。今天使用直流电源给这个反激供电,输出变压器噪音就小很多了(原来给反击供电的电源有2V左右的纹波,周期100Hz),但还是有一些,观察Mos的Ids波形,看其幅值大概以10KHz左右的周期变化(波形上升沿正常,无饱和现象),估计噪音就是这个10KHz的波形造成的。但是Mos的驱动占空比很稳定,空载电压23.98V 满载23.94V。     之前变压器异响严重,我感觉可能是环路没有调好,电源2V左右的周期性纹波进入2843的反馈换路了,下午再去试试调整环路。
2018/10/18 15:28:36
14
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长

下午试了下调整TL431的补偿环路R46、C47,原来是300K、300pF,后改为300K、10nF,空载电压24.0V,满载电压23.95V。第一幅图为Mos的Ids波形,第二幅图为输出电压纹波。满载时Mos管驱动波形稳定,占空比基本在33~34之间%。而且现在满载时变压器的噪音也很小,需要耳朵贴近才能听到。   准备晚上再试试使用2V纹波的电源带这块板子。

2018/10/18 16:51:08
15
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长

解决问题了,隔离地之间加102 Y电容就ok了,驱动占空比稳定,mos的Ids电流峰值一致。

原因分析:此反激电路峰值电流有12A,可能是Mos关断时较大的di/dt对uc2843的反馈回路或控制回路造成了干扰,从而影响控制。

希望斑竹可以帮分析下。

2018/10/19 08:43:09
16
boy59[版主]
电源币:215 | 积分:90 主题帖:50 | 回复帖:266
LV9
军长
反馈和控制回路的PCB是怎样的?看看有没有比较大的环路?
2018/10/19 09:13:57
17
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长
Q8、R33、U4、R46、C47、R46是一个挺大的环路,应该影响了反馈。     功率级环路和控制环路没问题,环路面积很小、单点接地。
2018/10/19 10:26:52
18
jlh213
电源币:59 | 积分:11 主题帖:5 | 回复帖:66
LV4
连长

看电流波形,还是有1.5KHz的纹波调整,这个是引起变压器声音的原因,感觉你的反馈环路还可以在调快些,比如把300K电阻再调小些,30K试试。

电流峰值差不多就是这个值吧,粗略计算:24*2.4/0.8=72W ,72/40=1.8A(有效值),(1.8A/0.33)*2=12A,峰值电流差不多也是12A。

2018/10/19 11:33:32
19
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长

加102Y电容后,24V输出就没有1.5KHz的纹波了,变压器异响也没有了。由于我的431反馈环路面积比较大,应该是被很大的di/di干扰了。反馈现在使用的是300K,470PF,看了下空载满载的切换时24V波形,调整速度比较快,所以没有做调整。第一幅图为满载时24V的纹波(LC滤波前级),第二幅图为空载满载切换时的24V纹波(LC滤波前级)。

2018/10/17 14:01:08
7
boy59[版主]
电源币:215 | 积分:90 主题帖:50 | 回复帖:266
LV9
军长
后面接的L4滤波电感也可能是引起压降的原因,TL431的电压采样点放在电感后试试。
2018/10/17 20:18:39
11
vega_mylove
电源币:20 | 积分:1 主题帖:10 | 回复帖:18
LV4
连长
您好版主,我下午做了些测试,回复在9楼、10楼了  请看一下
2018/10/17 15:36:43
8
hylylx
电源币:68 | 积分:44 主题帖:2 | 回复帖:1009
LV8
师长
该帖有赏
客服热线
服务时间:周一至周五9:00-18:00
微信关注
免费技术研讨会
获取一手干货分享

互联网违法不良信息举报

Reporting Internet Illegal and Bad Information
editor@netbroad.com
022-58392381